1. Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

    Dismiss Notice

Closed | Archived Wrong daily reward from festive buildings

Discussion in 'Archive: Bug reporting' started by NerelersCat, Apr 5, 2019.

  1. NerelersCat

    NerelersCat Novice

    Joined:
    Apr 5, 2019
    What exactly is the problem? Including a screenshot can help a great deal.
    Hi, Elvenar team,
    The problem is that actual rewards are not the same as their expected rewards from the description.

    photo_2019-04-05_12-30-23.jpg photo_2019-04-05_12-30-30.jpg photo_2019-04-05_12-30-51.jpg photo_2019-04-05_12-31-00.jpg


    Can you make the same problem occur more often? If so, how exactly? This information helps to find the cause of the bug.
    This problem occurs every time I am trying to collect rewards. Descriptions show one number, the real gathering is less than that.

    On what world did you encounter this problem?
    Felyndral

    When did you first experience the problem?
    As soon as I got those buldings
     

    Attached Files:

  2. Mr.Dave

    Mr.Dave Adventurer

    Joined:
    Dec 18, 2018
    I see the same issue. In the Carnival set, the only building that seems to work correctly is the Jesters Tavern. I have LOTS of screen shots from April 5 (5 per building) and not quite so many from 4/4 and 4/6. The issue is that "Current Production" (which includes all the Set Building level adds and Culture Bonus) shows up in a floating box near where the building is clicked when collecting. Up by the status bar, a completely different (and significantly lower) number appears, and it's that number that gets added to coins or supplies.

    I have all the Carnival set buildings, arranged as shown in the Set tab when you click on any of the buildings. All the set bonuses are not shaded and their amounts show consistently when you hover the mouse over a building, or click on a building and then select the Collect tab, then click on Production. The bonuses are ALL active.

    Here's a quick summary of my results from April 3 through April 6:

    __________________________ Coins _____ Supplies
    "Current Production" ___ 290160 ____ 242730
    Actual Added ___________ 221520 ____ 182010
    Missing __________________ 68640 _____ 60720
    Percent Missing __________ 23.7% _____ 25.0%

    The amount missing is not directly related to anything, meaning it doesn't always match any of the adds or culture or base production or some combination of these. Amounts vary depending on whether my overall Culture Bonus is at 150% or 160%. I have all the numbers in a spreadsheet, plus all the screenshots. Do you want me to upload?

    I'm in Winyandor. Fireworks and Banquet are at Chapter III, the other three are at Chapter IV.
     
    Last edited: Apr 7, 2019
  3. Dizzy Lizzie

    Dizzy Lizzie
    Ex-Team Member

    Joined:
    Feb 2, 2017
    Thank you for opening this thread. This issue has been passed to the Technical Team for further investigation and hopefully it will be rectified soon. In all likelihood, it is the tooltip which shows the incorrect information.
     
  4. Mr.Dave

    Mr.Dave Adventurer

    Joined:
    Dec 18, 2018
    Not just the tooltip, it matches all the other information available by clicking/hovering on the buildings. A different amount shows for a few seconds by the Status Bar, and that's what gets added. So not just a display issue. Thanks for looking into this!

    Update: Pictures added, in sequence of clicking. I'm in Chapter IV, Revelers Fountain is at Chapter IV level. Issue is similar for buildings from Chapter III level. Culture was at 160%, issue is same for 150% (different amounts). This is all for Revelers Fountain on April 5, today it was the same. Same for other buildings in set, anything involving coins and supplies promises a production level that is much lower when coins/supplies are checked. In this case, promised a supply increase of 35,280 (1st and 5th pics), but received an increase of only 24,990 (3rd pic, or subtract status bar amount in pic 2 from that in pic 4).

    I hope this helps you track down the issue! I have similar pics for the other buildings, and pics like the 3rd pic for many days on many buildings.

    Revelers Fountain 4-5 a.png Revelers Fountain 4-5 b.png Revelers Fountain 4-5 c.png Revelers Fountain 4-5 d.png Revelers Fountain 4-5 e.png
     
    Last edited: Apr 9, 2019
  5. Mr.Dave

    Mr.Dave Adventurer

    Joined:
    Dec 18, 2018
    I verified again yesterday, the amounts promised are still far more than amounts received.
     
  6. LazyTony

    LazyTony Sorcerer

    Joined:
    Jan 30, 2018
    Lizzie is correct, the buildings that produce supplies and coins have the culture bonus applied to the tooltip amounts displayed. Set buildings have never received a culture bonus, so its just a display error.

    Also, the new evolving buildings display a culture bonus. Not been up long enough for me to collect and verify that the bonus isn't applied, but I suspect it won't be.
     
    Last edited: Apr 16, 2019
  7. Mr.Dave

    Mr.Dave Adventurer

    Joined:
    Dec 18, 2018
    All appears to have been fixed since yesterday, thanks! Sadly, the Culture Bonus no longer applies to the Set Buildings bonus, so the promised number is now much smaller (but it matches what we've been getting all along). "Display Error" from programming perspective, "Not what I was led to believe" from a user perspective. At least it's cleared up now.
     
  8. LazyTony

    LazyTony Sorcerer

    Joined:
    Jan 30, 2018
    Same problem for me, display amount includes culture bonus, actual amount doesn't. It hasn't changed with today's update.
     
  9. Dizzy Lizzie

    Dizzy Lizzie
    Ex-Team Member

    Joined:
    Feb 2, 2017
    Yes, version 1.77 fixed the discrepancy between the 'promised' amount and what was received. The amount received has not altered since that was correct.
     

Top