• Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

Question Which Browser is best to use

Drew52

Novice
I have been using Google Chrome but I am now getting the "Hardware Acceleration Required" message despite it already being selected in my settings.
I am trying Firefox but it seems painfully slow and I am still getting the "Hardware Acceleration Required" message. :(
Are there tweaks I can implement or is there another Browser which performs better??
 

Herodite

Senior Forum Moderator
Elvenar Team

artemyren

Ex-Team Member
@Drew52 I know how it is, Herodite is correct put up a support ticket, we'll help you out, it's probably a log in issue, do you use PC or app?
 
Last edited:

Alcaro

Sorcerer
I have been using Google Chrome but I am now getting the "Hardware Acceleration Required" message despite it already being selected in my settings.
I am trying Firefox but it seems painfully slow and I am still getting the "Hardware Acceleration Required" message. :(
Are there tweaks I can implement or is there another Browser which performs better??
I use Chrome and once in a while I have the same problem - that message but HA already selected in Settings. I just close the browser and after restarting all it's fine. Since I have another city on the same server, for that one I use FlashPeak Slimjet - looks like Chrome but it uses less resources and it's kinda faster than Chrome. I gave up on Firefox long time ago.
 

Pauly7

Magus
Like @Alcaro I think Chrome is best, but I also get that error randomly too, for no reason. Usually just refreshing the browser fixes it. Sometimes I have to hit refresh two or three times though.
 

CrazyWizard

Shaman
Chrome is rhe best to use.
But if you use really old hardware (graphics) thats eol from its manufactorer for a long time and no longer suppported (usually graphics are supported for about 6-8 years since its first release)
The chrome also drops support as graphica drivers are no longer maintained and do no longer get security patches.

In that case firefox accepts it a bit longer but in general you need a hardware upgrade
 
Top