• Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

Update to 0.33

DeletedUser3

Guest
Dear Humans and Elves,

This is the discussion thread for the update to 0.33, our first update of 2016. As always, we look forward to your feedback.
 

Ecurb

Guest
I really dont know why you have persisted with making Hardware Acceleration a permanent feature. My game and I suspect many others just wont run correctly with it on.

Why does it need to be on permanently. Surely if it makes your game crap the smartest thing is to turn it off. Its not affecting anyone other than me if I turn HA off.

Means the end of the game for me because the lag is so bad.
 
Last edited by a moderator:

DeletedUser491

Guest
I want more exciting updates than this. Where are the sharks with lasers on their heads?

I would like more diversity, although this is a simple game, with simple goals. Its very binary. You're elf or human, and everyones cities look the same. Maybe more races, each with identifiable bonus' and penalties. Or the option to bespoke buildings with several versions.

Heck, even go "Black & White" on this game, and have the potential for good and evil cities!
 

Slotharingia

Guest
Since this update I have the issue that I cannot load the world map. Once this happens, reloading the game does nothing, I have to kill and restart the browser via the task manager.
 

DeletedUser815

Guest
Hello @Slotharingia,

The update to version 0.33 has not yet been implemented. You can easily see what the game version is by right clicking anywhere ingame and looking at the top line of the popup window that appears. And with the v0.33 update will come an improvement in the way the world map loads.
 

s5carrot

Sorcerer
Sloth,
turning off the hardware acceleration should be able to solve this issue. If all else fails
 

capitao.cesar

Guest
Sorry the Caps, but: DON´T TURN ON HARDWARE ACCELERATION BY DEFAULT!

We don´t (remember we don´t) have any 8 core processor or any nvidia GeForce GTX TITAN.

You say: "After many tests, we believe Hardware Acceleration is ready to become the default and only available option. This will grant us the possibility to take Elvenar to even higher standards"

I say: by using FLASH with laggy HA?
What a great noob DEV you have there.
We can´t even do polishes with HA enable, can´t scroll world map and the game experience is the worst possible.

Flash is dead and always was bad. Everybody knows it.Even youtube have now HTML5 available.

But if you want KILL Elvenar, go ahead.


 
Last edited by a moderator:

DeletedUser565

Guest
I can load the map but the lag is dreadful - Is this because of the new 'improvement' ?
 

Booff

Alchemist
:eek:
There is a big improvement with the fog of war on the world map, not perfect but the best I have seen in awhile.
The transition from one screen to another is fluent and the screen comes up perfect.
My computer is a 4gb single core laptop I bought the day Windows 7 was released making it more than seven years old. o_O
So I am happy with the update especially after I power cycled my computer and modem/router and performed windows update because before that it ran like Grrrr... :mad:

Everything should be made as simple as possible, but not simpler. Albert Einstein
 

Slotharingia

Guest
Thanks for your replies. I'd assumed it was due to an update as it started suddenly. Sorry for being dumb, I shall report if it continues to happen. As for now, I can load the map, but it takes ages. @s5carrot turning off hardware acceleration is no longer possible.
 

DeletedUser195

Guest
My problem with HA was never loading the World Map. I have always played the game, (4 cities) without it activated. Now, I have an issue, whenever I run my mouse through my cities, ALL of my buildings look like a celebrity is walking through the city, contestant flashing of the buildings. Also, the cities will move and scenery will stay in place, if I scroll buildings (more than one) to collect the goods, coins or supplies. Now that makes me take another sip of what I am drinking. Brings my younger days of the 70's back. Wow man, far out.
My Felyndral city, on US server and Winandor on the EN/International server is affected the worse, of my 4 cities.
 
Last edited by a moderator:

s5carrot

Sorcerer
yes. Hardware acceleration is now ON.

You can however go to options at your own Adobe flash player setting to set it OFF

Yes I noticed from yesterday onwards it either loads really slowly or just hangs there whenever the world is intended to load if the hardware acceleration is left on. works fine with it off
 
Last edited:

Katwijk

Guest
You can however go to options at your own Adobe flash player setting to set it OFF
Using the old Push Button Engine code is like dating your ex-girlfriend.

It's quite likely that the old (central processor) code for the Push Button Engine is still around, but various sources have stated that it's being ignored or removed and that, increasingly, features will be added that have no PBE equivalent, but rather depend on code that uses the graphics processor.

Take another peek at https://en.forum.elvenar.com/index.php?threads/activating-hardware-acceleration-for-everyone.860/. That's a Dear John letter in no uncertain terms.
 

s5carrot

Sorcerer
And as I have given my feedback on enabling that feature on this game. Screen hangs while loading.

It has never improved at all despite claims made here.
 

Slotharingia

Guest
I have to say that for me, after the period where I was constantly stuck in loading, the game seems faster now, though I do sporadically still get stuck in loading screens, but more like once a day rather than having to restart the browser constantly due to the game not loading anything anymore. However, whether this is due to the hardware acceleration or something else is impossible to say since the loading issues were apparently not due to any updates either ...
 

DeletedUser340

Guest
I just visited all my neighbours and the loading times were super fast. I never really had any problems with loading screens before 0.33. However, when the game was updated last week the loading times got significantly worse. If I'm correct, there was a hot fix and switching from towns to world map and vice versa is so smooth right now, even better than before 0.33. Good job Elvenar Team ;)
If that matters, I'm on Mac computer and using Safari browser.
 

s5carrot

Sorcerer
PS:
I have to add that things works fine once the hardware acceleration is off for me! The negative is purely for this item only.

There are some other aspects worth commending
 

DeletedUser3

Guest
Yes I noticed from yesterday onwards it either loads really slowly or just hangs there whenever the world is intended to load if the hardware acceleration is left on. works fine with it off

Which browser are you using please?
 

s5carrot

Sorcerer
firefox. I have tried chrome. NO improvements.

Most importantly, be it on or off, the battle encounters are now very choppy / laggy
 
Top