• Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

Open Teleport spell - error in the population requirement

Perte

Seeker
Hi devs and thanks for the amazing game!

My fellowship and I have been suspicious about the "teleport" spell population count for a while but today I was able to screenshot it!

Step 1
I'm about to summon a previously teleported steel factory
My population bar reports 4587 free citizens
The summoning popup asks for -4252 citizens
I confirm that I had to add residences to reach >4252 or the interface wouldn't let me summon this factory, so this population requirement is enforced.
bug 1_3 - 2022-05-13 at 09.16.19.jpg


Step 2
Her one can see my steel manufactory being summoned
However note that the population drop is not the same: -3598 instead of -4252 as reported in the previous step
bug 2_3 2022-05-13 at 09.16.27.jpg


Step 3
Here I'm confirming the summon, it's indeed the steel manufactory L24 that was in my inventory.
The population left is 989, confirming that the factory was requiring 3598 population and NOT 4252 as incorrectly reported by the summoning interface.
bug 3_3 2022-05-13 at 09.16.50.jpg


Step 4
I reloaded the game and all numbers stayed the same, I still have 989 population available.

This bug is annoying because:
- it forces us to provide extra population that ends up not needed
- if having no margin on population, when teleporting a building in inventory, it's not possible to summon it immediately back because of the incorrect extra population requirement.

Thanks in advance for the fix!

Bonus feature request: By the way, related to teleportations, if it was possible to show the population currently used by a building that would be great! When I need population and want to teleport a building into my inventory, I can't know how much population each building would give me back.
 
This bug is annoying because:
- it forces us to provide extra population that ends up not needed
- if having no margin on population, when teleporting a building in inventory, it's not possible to summon it immediately back because of the incorrect extra population requirement.

I have the same problem. It's caused by Golden Abyss and Mountain Halls population discount. I have both maxed so for me to retrieve a building I need to have 30% more population that it actually uses. It's the same with upgrades. I've made a suggestion for them to use the actual population needed but didn't get much notice. Any other wonders adjust the numbers in buildings so I don't understand why these two shouldn't.

Bonus feature request: By the way, related to teleportations, if it was possible to show the population currently used by a building that would be great! When I need population and want to teleport a building into my inventory, I can't know how much population each building would give me back.

I like that, at this moment the only way to see it is when you hover over it in the sell mode and that can be quite risky. :eek:
Also, who knows what kind of number it shows at this moment, discounted or not discounted.

And yes, I would consider this as a bug!
 

Perte

Seeker
Dear devs, if I may suggest a simple solution...
How about making the Golden Abyss and Mountain Halls rely on the TOTAL population instead of the WORKING population? TOTAL and WORKING are quite similar (in my case at the beginning of chapter 14 the difference is 0.005%)
That way we wouldn't have population swings when teleporting/summoning factories.
We would still have a bit of swing when teleporting back residences, but that wouldn't prevent summoning residences (which have no population requirement) so that easy fix would instantly make the situation better.

The other, longer fix is to have the summon interface take into account the AW bonuses.
 
Top