1. Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

    Dismiss Notice

Discussion Elvenar's HTML5 client

Discussion in 'General Discussion' started by Muf-Muf, Oct 18, 2018.

  1. Muf-Muf

    Muf-Muf Elvenar Team

    Joined:
    May 27, 2015
    Dear Humans and Elves,

    Please let us know your feedback about our new HTML5 client in this thread. We're looking forward to hearing what you think of it!

    Kind regards,
    Your Elvenar Team
     
    Kaliartis likes this.
  2. Lelanya

    Lelanya Shaman

    Joined:
    Aug 28, 2016
    For those who never seen Elvenar on HTML 5
    - the text is a bit different
    -there is a flicker whenever anyone posts to chat, but it is not creeping
    -battle screen is loading smoothly no errors (@yo momma love me here is your fix)
    - no flash crash
    -game loads faster
    -tech tree is intact

    THANK them for us pls @Muf-Muf
     
    Rigr and Kaliartis like this.
  3. Killiak

    Killiak Illusionist

    Joined:
    Aug 4, 2016
    - The text in the game is a bit smaller, which will take some getting used to.
    - The chat reload every time someone posts is annoying. Really gets on my nerves.
    - For me, the game loads a lot SLOWER
    - The entire game seems a good bit slower
    - Battle is doable, but again; slower

    This is on Firefox, and on my laptop. So perhaps Chrome will treat me better. I will post or edit that in later.

    Also, perhaps my home PC will perform better as well. It has a a lot (a LOT) more power.
     
  4. Timneh

    Timneh Illusionist

    Joined:
    Dec 4, 2016
    I'm also on Firefox and the game loads a lot slower for me as well. The tech tree was just a blank page when i tried to go in to it. I have switched back to the flash version now, might try HTML5 again later. I had a couple of other sites open in different tabs at the same time so i don't know if that would make a difference.
     
  5. Kaliartis

    Kaliartis Soothsayer

    Joined:
    Dec 1, 2017
    Using Chrome here, just noticed 2 things that are a bit annoying:

    1- Can't copy as before the players name when opening a message with him (it takes it as an image and the only choice is copy image)
    2- In the rankings tab, can't view a selected fellowship like before (you have to first go through a player to see his fellowship details..)

    To be continued..
     
  6. m4rt1n

    m4rt1n Necromancer

    Joined:
    Apr 9, 2017
    I'm using Firefox, and currently cannot get the game into full screen mode so will be switching back to flash.
     
  7. Thagdal

    Thagdal Soothsayer

    Joined:
    Apr 5, 2018
    Carrying on from Kaliartis's post, theres no right click options (on PC, tested on Chrome, Firefox and Opera) to go to forum or support in HTML5 mode, so its now extra clicks and longer mouse time to use the embedded forum button or support button...:(:D
     
  8. Thagdal

    Thagdal Soothsayer

    Joined:
    Apr 5, 2018
    @m4rt1n just tried full screen on Chrome Firefox and Opera and it works on all 3 for me...update Firefox maybe?
     
  9. Lelanya

    Lelanya Shaman

    Joined:
    Aug 28, 2016
    Battle screen flicker is here. Did not get at home
    I can still open a context menu for players
    Cannot do same for View Fellowship tho; same workaround as for Beta
     
    Last edited: Oct 18, 2018
  10. Kaliartis

    Kaliartis Soothsayer

    Joined:
    Dec 1, 2017
    Shouldn't all this be tested first on Beta and only launched live when everything is fixed? Are we the new Beta testers?
     
  11. Lisica

    Lisica Illusionist

    Joined:
    Aug 13, 2015
    We've had it on Beta for a while now, seems that bringing it here is a bit like having a mobile version which doesn't do everything the PC version does - do first and then make small corrections later over a long period of time, so that when something happens we're all grateful to have it fixed and completely forgotten that it should have never been produced with all those problems to begin with!
     
    ctik, shadowblack and Kaliartis like this.
  12. Lelanya

    Lelanya Shaman

    Joined:
    Aug 28, 2016
    It is better than the initial Beta release. There are no lines and the tech tree is still visible
    Try clearing cache. I know it is said often but it may be helpful
     
  13. Shadow Mike

    Shadow Mike Soothsayer

    Joined:
    Dec 1, 2015
    No problem playing the game with Opera browser on htlm5 . Only set back is , like Thagdal wrote, theres no right click options to go to the forum or facebook page or support .
     
  14. Lelanya

    Lelanya Shaman

    Joined:
    Aug 28, 2016
    I have a fellow who tried it for 12 hours and disabled it. He said the battle screen kept crashing. He was running on Chrome
     
  15. Lisica

    Lisica Illusionist

    Joined:
    Aug 13, 2015
    I tried it with Opera but couldn't get the tree to load at which point I gave up, either its working properly and I'll use it or it isn't and I won't...
     
  16. LadyHavva

    LadyHavva Scholar

    Joined:
    Mar 8, 2018
    I must say that other than the flicker in chat it is working very well for me. I'm using it in Chrome. One thing though, when I use /who in chat I get one players name twice. Repeating the command to see if it's just a glitch and will disappear, still comes up double with the same players name. Don't know if it's always just one player, a certain player etc. I'll try it a few more times and report back what I find.
     
  17. Lelanya

    Lelanya Shaman

    Joined:
    Aug 28, 2016
    Haha I remember that error, we got that in Winyandor a while back.
    Tech tree has vanished in one of my large cities so that's it for me, til the patch is applied.
     
  18. Kaliartis

    Kaliartis Soothsayer

    Joined:
    Dec 1, 2017
    It happened to me as well, the doulbe name was mine in my case! :D
     
  19. Timneh

    Timneh Illusionist

    Joined:
    Dec 4, 2016
    I just tried switching to HTML5 again and it still took ages for the game to load, still can't access the tech tree and it is very jerky when i move around my city so i am finished with HTML5 until it is sorted out.
     
  20. Muf-Muf

    Muf-Muf Elvenar Team

    Joined:
    May 27, 2015
    Thanks for your feedback all!

    Will do!

    We're aware of this happening with the Chrome browser in version 69. With version 70, it has already been resolved. Just update your Chrome to the latest version, and the problem shall be gone! :)

    We've been testing the HTML5 client since mid June this year on Beta. In the 4 months since then, we've made major progress, and we now believe the client is performing well enough to be slowly rolled out to all of our versions (starting with the EN version yesterday). This will allow us to get even more feedback, and since the new client is completely optional, we believe this is not causing any issues for anyone who's not interested in the new client, while also offering it to those who would want to use it already. We're well-aware that it's not fully perfect yet, and that's exactly the reason that it is optional to use. :)

    They'll soon be added! You'll already be able to enjoy them on Beta, and that also means they should reach the EN worlds with the next update already!
     

Top