• Good day, Stranger! — Are you new to our forums?

    Have I seen you here before? To participate in or to create forum discussions, you will need your own forum account. Register your account here!

Open Buggy troops instant sales push

Lelanya

Artisan
I cannot sign in to any of my cities, on any live realm, not here on the International Server, nor on the US server. I've tried differing realms, and alternate browsers, they all say "Sorry, an internal error occurred, please try again later".
I normally use Google Chrome, and lately have been resorting to Mozilla Firefox for my alternate account, as switching back and forth has become difficult. I also tried Microsoft Edge in the interests of being thorough, which loads the Flash version of the game, with the same results.

My phone is coming up with "Something went wrong" when I essay to load the mobile version of the game, and I get this error whether on wifi or cellular data.

Beta realm loads, guess I'm helping my fellows there.
 

Vopica

Novice
Same issue here, Mozzila firefox and Android 7 phone as well ... unable to play due to "Error" "Sorry, an internal error occured. Please try again later"
Basically game loads successfully and welcomes me with this error that either forces me to reaload (after which i get same error again) or close the browser in disgust ...
 

Lelanya

Artisan
You would think the staff might be interested in assisting us.. yeah, my phone is Android, if that's any help
 

Lelanya

Artisan
Yes, it's possible to use the game features in behind the push attempt to reload, I've a ticket on the US server, and this is how I arrived at the Forum; I've also posted on Fellowship Chat, to let my Iceni know this is a global issue
 

Lelanya

Artisan
I'm back in, I will test my various cities, and Edit this post as I find them.
All three browsers are working now, and all of my realms to date
 
Last edited:

Pauly7

Mentor
I haven't had any problem today on app or browser. It doesn't look like the issue is universal.